Помощь - Поиск - Пользователи - Календарь
Полная версия этой страницы: Rhino под Linux? Да!
Форум .:3DCenter.ru:. > Пакеты 3D моделирования > Rhino
Семён
Всем привет!

Друзья, у меня хорошие новости и для линуксоидов, и для риноводов - теперь наша любимая рина стала немного кроссплатформеннее D.gif

Удалось поставить .Net 4 под wine и запустить пятую рину под Fedora 17 x86_64. Уже отписался на winehq - должны добавить новую версию в базу. Rhino пока нельзя назвать полностью рабочей под линуксом - она даже запускается с ошибками, но это все же большой прогресс по сравнению с предыдущими версиями, которые ставились-то с трудом. Сейчас можно что-нибудь порисовать, построить несложное, но проблемы с диалоговыми окнами делают некоторые инструменты, к сожалению, неюзабельными.

Вот скриншотик рины под линуксом (просто импортировал старую модельку):

WawaNN
Семён, а как же Мак, помнится ты собирался продать душу Эпплу, что Давид победил Голиафа, Линукс победил Макинтоша? biggrin.gif
Семён
QUOTE (WawaNN @ 02/12/2012, 09:32) *
Семён, а как же Мак, помнится ты собирался продать душу Эпплу, что Давид победил Голиафа, Линукс победил Макинтоша? biggrin.gif

Именно! Я последнее время все больше и больше как-то отходил от 3d графики (даже здесь не появлялся уже почти полтора года) и мне нужен был софт, который лучше работает под линуксом (я и на макось перешел из-за этого - unix все-таки). Последним, что держало сначала на Windows, а потом и на Mac OS, была рина. Но все же научился моделить поликами в блендере и на какое-то время про Rhino забыл. А недавно пришла рассылка от McNeel - и вот, носорог расширил ареал своего обитания, пусть и с оговорками smile.gif

Из эппловской техники у меня только iMac, на котором установлена только Fedora wink.gif
WawaNN
QUOTE
Из эппловской техники у меня только iMac, на котором установлена только Fedora wink.gif

Месье знает толк в извращениях. smile.gif
А я вот дальше пробной Убунты не заходил, как думаешь с Убунтой можно попробовать? Если появится возможность установить под линуском полную рабочую Рину, буду только рад.
QUOTE
Но все же научился моделить поликами в блендере и на какое-то время про Rhino забыл.

А чем T-Splines не устроили? По сути те же полики, подглючивают правда когда их много, а так вполне.
На макниловском сайте (давно не заходил) смотрю уже пятеркой торгуют, что уже релиз был?
Семён
QUOTE (WawaNN @ 02/12/2012, 17:35) *
Месье знает толк в извращениях. smile.gif
А я вот дальше пробной Убунты не заходил, как думаешь с Убунтой можно попробовать? Если появится возможность установить под линуском полную рабочую Рину, буду только рад.

Есть немного ) Если бы изначально брал компьютер под линукс, взял бы что-нибудь другое. А так, железо очень хорошее, и, слава Богу, все работает и под линуксом.

С убунтой, конечно, стоит попробовать. Насчет полной рабочей - скорее всего, не скоро это будет, если вообще будет. Там какие-то серьезные проблемы с диалоговыми окнами - под вайном их содержимое рисуется в рутовом окне (как-то в обход оконного менеджера). Пользоваться можно, но неудобно. Вот в MoI 3 обещают полную совместимость под вайном (у нее платиновый статус на winehq) - думаю, то ли ее попробовать, то ли Rhino дальше копать, то ли пока опять забыть про нурбсы.

QUOTE (WawaNN @ 02/12/2012, 17:35) *
А чем T-Splines не устроили? По сути те же полики, подглючивают правда когда их много, а так вполне.
На макниловском сайте (давно не заходил) смотрю уже пятеркой торгуют, что уже релиз был?

Есть вещи, которые проще и лучше делать обычными поликами, есть вещи, для которых нужны нурбсы. Мне почему-то кажется, что T-сплайны либо для тех, у кого большой опыт полимоделинга и кому трудно перестроиться на логику моделирования чистыми нурбсами, либо для фанатов нурбсов, которым все равно что, лишь бы в итоге были нурбсы. Могу ошибаться, так как сам с Т-сплайнами не работал.

Пятерку да, уже продают. Правда в рассылке она называлась Prerelease.
WawaNN
Ну да, видно Ти-сплайны для таких как я, у меня на выходе сейчас смесь нурбсов с поликами в одном флаконе, некоторые детали гораздо проще и быстрее внутри Рины сделать Ти-сплайнами, считай поликами ( всякие хитрые зализы, фюзеляжи, законцовки и т.п. в авиации), а некоторые нурбсами. К тому же если экспортировать в Макс Ти-сплайны как полики, через 3ds, то в Максе получаем полноценные эдитейбл поли, которые почти адекватно сглаживаются, и имеем нормальную сетку.
roco.constantin.b
не издевайтесь над собой и над другими.
Тут фотошоп запускаешь и грубо материшься, так как половина инструментов глючит а вторая тормозит.
Альтернативы нет, но может быть, когда нибудь, автодески сделают алиас под линь (как это стало с мудбоксом)
bodja
Ну вообще то можно не париться и вместо WINE поставить себе на LINUX , VIRTUAL BOX
так гораздо меньше проблем и полноценный Windows на линуксе ))
Семён
QUOTE (roco.constantin.b @ 03/12/2012, 00:27) *
не издевайтесь над собой и над другими.
Тут фотошоп запускаешь и грубо материшься, так как половина инструментов глючит а вторая тормозит.
Альтернативы нет, но может быть, когда нибудь, автодески сделают алиас под линь (как это стало с мудбоксом)

Так это просто спортивный интерес ) Никто и не издевается. Сам использую пару программ под вайном, у которых золотой статус совместимости - никаких проблем, как родное приложение. Ничего не тормозит, все работает из коробки, даже поддержка wacom-овского планшета. Если все так и будет с MoI 3, как и обещают (а платиновый статус говорит о многом - у самого пока нет возможности проверить), то вот она и альтернатива. А алиас (в свою бытность еще StudioTools) был под линукс до покупки его автодеском.

QUOTE (bodja @ 03/12/2012, 08:15) *
Ну вообще то можно не париться и вместо WINE поставить себе на LINUX , VIRTUAL BOX
так гораздо меньше проблем и полноценный Windows на линуксе ))

VirtualBox - не замена wine. Потому что как раз под виртуальной машиной наблюдаются заметные тормоза + ресурсов жрет она немало. А с вайном все намного проще.
bodja
Ну тогда вот тебе видео
это пример установки дополнительных библиотек и приложений в WINE:
Microsoft Visual C++ 2003;
Microsoft Visual C++ 2005;
Microsoft Visual C++ 2010;
Microsoft .NET Framework 2.0;
Microsoft .NET Framework 3.0;
Microsoft .NET Framework 3.5;
NVIDIA PhysX;
Games for Windows-Live;
Windows Media Player 10;
и многое другое.
Время: 28мин.
Формат: .avi, 1280x1024, H.264, 25кадр/сек.
http://depositfiles.com/files/lol628eyy

без этих настроек может Rhino и не заработает по крайней мере правильно
но учти что перед настройкой своего Linux надо узнать от каких библиотек и API зависит Rhino тогда дело будет в шляпе
P.S Это видео больше для Ubuntu но может и тебе что то пригодится утилита называется Winetricks
подробней о ней можно узнать здесь
Семён
Для 5-й версии Rhino нужен только .NET версии 4.0.
bodja
Цитата(Семён @ 11/12/2012, 17:29) *
Для 5-й версии Rhino нужен только .NET версии 4.0.

Я на тот случай если кто то ещё пользуется Rhino4
ITdreamer
Цитата(bodja @ 11/12/2012, 18:37) *
Цитата(Семён @ 11/12/2012, 17:29) *
Для 5-й версии Rhino нужен только .NET версии 4.0.

Я на тот случай если кто то ещё пользуется Rhino4


Запуск любых серьезных приложений под wine - форменное извращение!
Для просмотра полной версии этой страницы, пожалуйста, пройдите по ссылке.
Форум IP.Board © 2001-2019 IPS, Inc.